Paquete .deb para Ubuntu: correcta dependencia de Java

Actualmente estoy en el progreso de crear un paquete .deb de nuestra aplicación basada en Java, especialmente para los usuarios de Ubuntu. Nuestra aplicación funciona con JRE 1.6 y 1.7 de OpenJDK ( openjdk-6-jre-headless y openjdk-7-jre-headless ), pero se prefiere el uso de JRE 1.7. Por eso estoy usando

 Recommends: openjdk-7-jre-headless 

Pero no estoy seguro de si esta es la dependencia correcta. Al instalar nuestro paquete y no está openjdk-6-jre-headless ni openjdk-7-jre-headless , debe instalar openjdk-7-jre-headless .

Debes depender de java-runtime-headless (>= 1.6) (que es llenado por openjdk-7-jre-headless , y permite que cualquier 1.6 o más reciente JRE que el usuario ha instalado para trabajar).

Esto permite una mayor flexibilidad. Por ejemplo, ejecuto oracle-java8-jdk en mi sistema; Esto proporciona default-jre-headless 1.8 (así como java7-runtime-headless , java6-runtime-headless y java5-runtime-headless ), pero cualquier dependencia sobre openjdk resultaría muy probablemente en mi no instalar tu programa porque tengo No deseo de instalar un antiguo JRE.

    Intereting Posts